Welcome, Guest
Username: Password: Remember me
Use this Category for your support questions about Virtuemart Template - PureMart (SKU# FLEX-00010)

TOPIC: Cart Module randomly doesn't add products properly

Cart Module randomly doesn't add products properly 7 years 10 months ago #7351

Joomla 2.5.16
VM 2.0.22C (though this issue also happens in 2.0.24b)
PHP 5.3.27
Puremart 3.8
95% of products are parent/child with stockable variant

We have had a niggling problem for quite some time, which we have often ignored.
But now as our site is getting a LOT more traffic users are complaining of the problem on a daily basis.
I have tried all sorts of things to try and fault find and prove other parts of the site are OK & these are listed below;

This is pretty intermittent, in that it happens in all browsers, more so in Chrome & may happen when adding your very first product or 2,3,4,5th or even 10th product?
It happens with both parent only and stockable products, from all different sources - Home page, category page, manufacturer page.

When adding a product to your basket, you see the product has been added in the puremart cart module as it now displays 1 product.
but if you hover over the puremart cart module to view, there SOMETIMES is no product.
If you click on go to cart/checkout, when you get there, there is no product.

As above, though, this is quite random, so you might be able to add 2-3 products, but then when you view in the puremart cart module, you see 1 less item and the same is when you hop over to the cart page.
I took some screenshots of this happening, where I have just added a product.
You can see in the screenshots, that the cart module shows 5 products, but only 4 show in the cart module. If I was to click on the "Checkout Now" button here, I would only see the 4 products on the checkout page.

If I rename the templates/mytemplate/html/mod_virtuemart_cart to something else then obviously the cart module now looks very messy as it doesn't use the puremart overrides, but it works perfectly every time.

Do you know what may be causing this issue?
Have you seen it before?
Any advice on other things I can checkout?


Switched VM jQuery in backend configuration setting to different configuration tried off/on, etc
We use jquery easy plugin - I tried this off & on.
Switched to Beez2 template
Re-installed puremart 3.8 & plugin
Re-installed Virtuemart 2.0.22C & also tried with 2.0.24B
Tried with all site cache, CDN settings off, site cache cleared and browser cache cleared
We use Rupostels OPC, I have updated this and switched it off to use the puremart checkout

Attachment ScreenShot2013-11-13at11.18.40.png not found



Attachment ScreenShot2013-11-13at11.09.58.png not found

Last Edit: 7 years 10 months ago by Andy Connell. Reason: correct my poor spelling!
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 10 months ago #7360

Hi,

I have exact the same problem with the cart. The problem is, that when I add s.th. into the cart, the product goes directly to the cart. But when I refresh the page or try to move to the checkout, the product disappears again from cart.
I'm using the Ajax Dock Cart from Offlajn, but I also tested it with the standard cart given by my Puremart theme (latest) I use.

In my case the problem started with VM version 2.0.24.

Now I'm in use of VM 2.0.24b, Joomla Version 2.5.16 and PHP version 5.3.18 and the issue still exists.

Sometimes it works, but most of time not.
I also tried what Andy Conell tried, too, but I had no success!
I also wrote in the official VM forum, but they told me it may be a Theme problem / 3rd Party issue.

My shop starts soon, but is currently offline. If you need access data I can provide it via Email.

Thanks in advance!
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 10 months ago #7375

Guys, you should be aware that, the shipping cart module stylization that comes with the PureMart is nothing complex. It is not a module, it is not a plugin. it is nothing but CSS stylization. The only thing we have changed is the "appearance" of the official VM - Virtuemart Shopping Cart, by using the template overriding and adding extra CSS lines.

The process of JSON by AJAX while adding product to cart event is still handled by the Virtuemart core files.
Styling the "VM - Shopping Cart" is the "extra" feature that comes with the PureMart and can be disabled easily.
To disable the PureMart "VM - Shopping Cart" stylization you can rename this folder:
/templates/YOUR_TEMPLATE/html/mod_virtuemart_cart/
to
/templates/YOUR_TEMPLATE/html/mod_virtuemart_cart2/

and get back to original VM - Shopping Cart Module layout. I am 100% the result will be the same, but give it a shot. If you still encounter problem of not being able to add product to cart proper [sometimes] there are some other factors may involved. read here for more explained information;

www.flexiblewebdesign.com/forum-virtuemart-2-template-support/1556-premium-support#7276

FYI Christos Farakos, did you try to contact the AJAX dock cart developers? Because you are using AJAX cart, so the page shouldn't be redirected to shopping cart automatically, otherwise the word of AJAX would be pointless. I guess this is fallback even, because the AJAX doesn't work. There must a jQuery conflict error which avoid AJAX request during "adding product to car"t event, check your website with using FireBug and look for the console error. If you see a RED WARNING, then contact the AJAX DOCK CART developer about the jQuery conflict issues. Also did you test it with the official VM - Shopping Cart module? (To get the official VM - Shopping Cart module, you should also rename this folder:
/templates/YOUR_TEMPLATE/html/mod_virtuemart_cart/
to
/templates/YOUR_TEMPLATE/html/mod_virtuemart_cart2/

Is the result same? It can't be though.

regards.
Support
Last Edit: 7 years 10 months ago by Support.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 10 months ago #7381

Hi,

thanks for your answer.

So finally I renamed the mod_virtuemart_cart folder and disabled the Ajax Dock Cart and the issue is still there.
It happens exactly the same as before.

Any ideas?
I'm just trying to figure out, what may cause this problem, so I will write the same to the official VM forum.

EDIT:
Please notice: I also renamed now the whole com_virtuemart folder in my template and now everything worked.
I tried it with and without the Ajax Dock Cart and it worked both times.
Last Edit: 7 years 10 months ago by Christian Fenderros.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 10 months ago #7384

I just saw, that there is a new Puremart supporting 2.0.24.
I just wrote to the Update Forum post.

Maybe it can make the change. I will try it.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7407

Unfortunately I had no succes by using the new Puremart version.

What can cause this issue?

I'm getting desperate, because I have no idea what happens.
Support Team, can you take a look, please? It's urgent.

@ Andy Connel: Did you find a solution that works for you?
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7408

Hi,

I read the advice here www.flexiblewebdesign.com/forum-virtuemart-2-template-support/1556-premium-support#7276 and basically this says disable Display modal popup upon 'Add to cart' - But this is not really an option for me.

We ran our store on VM2.0.18 using Puremart 3.4 for a LONG time all working fine.
It was only when we updated to VM2.0.22C & Puremart 3.8 that we started to notice this issue - more often in Chrome

Our store runs on a dedicated (powerful) siteground server, so I'm pretty confident that the server is adequate, though our main live site does use caching and Cloud CDN also.

I have tested in a staging/copy site with all the cache switched off & I still notice the problem with adding products to the cart, sometimes OK, other times it doesn't get added.
I have also tried should also renaming this folder:
/templates/YOUR_TEMPLATE/html/mod_virtuemart_cart/
to
/templates/YOUR_TEMPLATE/html/mod_virtuemart_cart2/
And the result for me as I have already mentioned in my first post is that adding to my cart after renaming the overide files works well EVERY time, although the cart module is now messy?

I have also tried disabling this all together and tried using PixelPoint's Quick Cart Summary Module & again this works well every time I add to cart.

So for me this only seems to happen with the purmart cart overide setting's. I have tested this a LOT & not just rushed over it. Ive tested it with VM2.0.22C & 2.0.24B, with cache's off and on and in all browsers.

Also as this has worked for so long with 2.0.18 & purmart 3.4, my client likes the puremart cart, so swapping to the PP Quick mart summary isn't really an option.

Would really appreciate any other help/advice and willing to pay for any sort of premium support to take a deeper look into my site.

Andy

EDIT Also I just wanted to let you know that I tried this in a copy/staging site using just Beez template, reloaded puremart 3.8 (So we know all default files are being used) and still getting the same results.
Last Edit: 7 years 9 months ago by Andy Connell. Reason: Added extra information
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7425

What about some support @ Flexible Team?

I understand, when you say, that it is no Puremart issue.
But when official VM forum developers say that it has to be a theme/3rd party issue, it is hard to figure out what's actual the problem. And it's much harder to find a solution...

So we tried a lot to figure out what can cause the add to cart problem.
Give it a try and take a look at one of our websites.

It is urgent!
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7431

As an idea for further testing, is there any way to disable the add to cart button, until the page has fully loaded in the users browser?
It was explained here www.flexiblewebdesign.com/forum-virtuemart-2-template-support/1556-premium-support#7276 that this problem maybe because the user is adding the product to the cart before the page is fully loaded.

If this is the case could loading the addto cart function last, solve this problem?

#justathought

Andy
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7475

Hi Andy,

About your #justathought, might sound logical but i don't think it would work at all.

there is one more thing you might do. Try to enable this the "Fancybox" option:

Attachment Pasted_Image_11_27_13__3_07_AM-4.png not found



And re-test and see if the problem is still continue.

If even though the "fancy box" doesn't solve the issue; could you guys please provide me your website's URLs to let me run some tests?
Please also clarify these:

1- Is this is a browser thing? or is this happening in all browsers? (both chrome and firefox)
2- Is there any specific location where this failure happens? (category page or product details page)
3- Does this happen just randomly? (like; you click the add to cart button, nothing happens, you click again, the product gets added to cart, you click button again but nothing happens this time.. so forth.. which is the worst case, random behaviors are the hardest one, because it is hard to figure out what is wrong)



Regards.
Last Edit: 7 years 9 months ago by Support.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7490

Hi,

First of all I activated the fancy, but then the cart popup suddenly disappeared. But more relevant is, that the issue happened again.

Concerning your questions:
to 1) it happens in every browser
to 2) in my case I just use the product details with add to cart function, so it happens just there
to 3) yes, unfortunately it happens randomly (worst case)

!! BUT let me say, that I tried to do like Andy mentioned in his last post. When I wait until the page loads completely and when I add then s.th. to the cart it works EVERY time. So right now for me it seems like I just have the issue, when I click on add to cart BEFORE the page loads completely.

Maybe this is in fact s.th. what could bring us nearer to a solution...

I will send you now via email the login data and also a link to this post here.

Thank you!

Edit: Email just send to This email address is being protected from spambots. You need JavaScript enabled to view it.
Last Edit: 7 years 9 months ago by Christian Fenderros. Reason: more info
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7502

HI,

I have a full working copy of my Website here on the same sever, with all caching, CDN, etc off
You can have full admin & FTP access to do anything you want in here is it is just a testing (although carbon copy) site, that was added yesterday.

I enabled fancybox and too still encountered the same issues as I have been having.
1- Is this is a browser thing? or is this happening in all browsers? (both chrome and firefox)
Happens in all browsers, Though I seem to notice it more in chrome?
2- Is there any specific location where this failure happens? (category page or product details page)
Anywhere, Category page, product details.
3- Does this happen just randomly? (like; you click the add to cart button, nothing happens, you click again, the product gets added to cart, you click button again but nothing happens this time.. so forth.. which is the worst case, because random behaviors are the hardest one, because it is the hard to figure out what is wrong)
Yep fairly randomly, sometimes I can add 1 product to cart and it not be there, other times I might get to 10 products before I notice it.

See my screenshot, as when adding a product, it shows in the cart module, but when you hover and view your products it doesnt show in there. & If I navigated to the checkout page the products also would not be there.

Andy

Attachment checkout-prob.jpg not found

Last Edit: 7 years 9 months ago by Andy Connell.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7514

Hi,

Before jumping into this problem, here is my suggestion..
for both of you guys, would you consider switching from PureMart to CleanMart?
I can replace your products from PureMart to CleanMart right away without any extra cost.
CleanMArt demo: demo.flexiblewebdesign.com/cleanmart/

And you can install the CleanMart to your website, run the same tests. If the failure continues, then there is no an alternative way, i will spend time no matter how long it is and try to figure out the problem. But if CleanMart solves the problem. Then we are rock!!

And one more thing. Please do this as a favor to me. To the same testings as you are doing in our DEMO server:
demo.flexiblewebdesign.com/cleanmart/
demo.flexiblewebdesign.com/puremart/

and see if our DEMO server also creates any problem (both CleanMart and PureMart demo pages are using VM2.0.24c, which is the latest as of now)

Regards.
Support.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7517

Hi,

I tested if the issue occures on your DEMO themes, too. I tested for both CleanMart (by the way I love it!) and PureMart itself.
And indeed, the issue happens to me again there for both themes.

Actually it just happens, when I don't let the page load completely and click on add to cart. Otherwise when I wait until the "URL loading image" in the browser bar has stopped and I click then on add to cart, then it works every time.
Last Edit: 7 years 9 months ago by Christian Fenderros.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7527

Hi Christos.

I guess we have made a big progress here, at least we know what the "real problem" is. The problem is clicking the "add to cart" button without waiting the modal popup plugin gets loaded.

The Fancybox or Facebox (depends on which ever is chosen in VM Backend) is triggered when the addToCart button is clicked, of course loading those plugins and attaching them to DOM takes time, no doubt about it. Trying to trigger them without they got loaded will result an error, there is no surprise here. As i have mentioned here:

The best way to minimize risk is to disable the "modal popup upon add to cart". So once you added product to cart, the page will be redirected to shopping cart page. Since it is a ordinary form-submit event, (nothing is going on behind the scene in terms of AJAX). It will eliminate the add to cart failure that caused by not loaded modal popup plugin. You can disable the modal popup feature from;

VM Backend > Configuration > Checkout
and disable Display modal popup upon 'Add to cart'

But, we all love that "modal popup" and we don't want to disable that, right? Then there is no any other way unfortunately but making the website as fast as possible. The the modal popup plugin gets loaded almost instantly, so the visitor won't experience any failure during adding product to cart.

Using GZIP on JS&CSS files, enabling the "cache" (just enabling the Joomla Cache won't help too much, there are more professional way to activate cache, server-side PHP XCache is one of them), using external server for static contents (CSS, JS and IMG files) etc. etc. etc.. There are tones of other ways to increase the page loading performance.

Read this article for more info: developer.yahoo.com/performance/rules.html

And analyze your website through: developers.google.com/speed/pagespeed/insights/

Google Insight will suggest the things you need to do for speeding up your website.

Regards.
Support
Last Edit: 7 years 9 months ago by Support.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7570

Hoping for just some discussion now, that we are getting somewhere.

My site is already on a dedicated server from siteground, which has Joomla booster added to it, uses there own supercacher tool, gzip & compression settings as well as Cloud CDN as well, to all help provide the site in fastest possible way.

Is there no way to order this "modal popup plugin", to always load first or maybe faster somehow?

Also, when I use another cart module from "PixelPoint QuickCart", which is an ajax type cart this seems to work fine? although it seems the item doesnt add to the cart for about 1 second.
I have tried adding products fast as possible and event going to checkout page fast & this always adds the products?

Christos - Can I send you a copy of Pixelpoint Quick cart for testing on your side?
If so mail me at andy871 at gmail dot com
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7613

Hi and thanks for your answer.

Disabling the add to cart popup is no solution indeed. Of course I'm trying my best to make the site as fast as possible, but I think there has to be a better solution for it. The site is much faster now and the chance to get this issue was minimized, but is still there. Like Andy said, changing the loading order for modules or for the cart button could be a solution.

I have no idea... you are the specialists. ;) Is there no other solution?
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7738

Hi, i wold like to report that i have the same problem, with VM 2.0.24 and LightMart template. I wonted to publish the site tomorrow and after i tested the site properly this...

I have also tried all sorts of things mostly mentioned here and problem is here.
The solution with disabling the add to cart popup is big no no, as i have 8000 products I have to much problems with speeding the site up as it is, so solution that puts user on cart page after adding every product is out of the question, as the site is for wholesales trade and its fare to predict that many products needs to be aded to cart and its to slow as it is.

Please let me know if any of you fixed this problem.
Last Edit: 7 years 9 months ago by ikik.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7742

And just a tip for others, after testing few extensions.joomla.org/extensions/extension-specific/virtuemart-extensions/virtuemart-orders/24421 seems to do the job whiteout problems, only thing that does not do is adding products from quick view so i disable it, but tiny add to cart button works. It needs little playing with css but its free and it does the job...
Attachments:
Last Edit: 7 years 9 months ago by ikik.
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 9 months ago #7793

Thank you Ikik.

It is so good to see that people are helping each other and share their suggestions.
Looks like using a 3rd party module (which uses its own AJAX script, instead of using Virtuemart's scripts) is our best bet for now. -OR- disabling the Display modal popup upon 'Add to cart'.

This plugin looks good:http://extensions.joomla.org/extensions/extension-specific/virtuemart-extensions/virtuemart-orders/24421
and since it is a freeware module, it is worth to give it a shot.

Regards,
Support
The administrator has disabled public write access.

Cart Module randomly doesn't add products properly 7 years 8 months ago #8009

Thanks ikik for taking the time to let us know of this plugin, I downloaded and installed it and having a couple of minor problems that I sent a support question over to the DEV, But I just wanted to mention a couple of things here too.

Firstly, using this seems to remove my modal popup function when adding a product to the cart - did you get the same? This is what I sent a support request.

But also and maybe a bit more worrying, after install I noticed a new PHP file in the root of my Joomla site called "mvm_quickcart_ajax.php"
I'm not sure that this is some sort of security issue? Ive never seen PHP files in joomla root before for modules or components.
Just also wanted to get anybody's thoughts on this?

Andy
Last Edit: 7 years 8 months ago by Andy Connell.
The administrator has disabled public write access.
Time to create page: 0.150 seconds

MaterialMart

for Virtuemart 3

Google's Material Design has finally arrived to Virtuemart

Virtumart Template - MaterialMart Virtumart Template - CleanMart Virtumart Template - CleanMart Virtumart Template - CleanMart

Fully responsive!

Buy Now   |   Live Demo