Welcome, Guest
Username: Password: Remember me
Use this Category for your support questions about Virtuemart Template - FashionMart (SKU# FLEX-00008)

TOPIC: Manufactuers Logo Not Showing

Manufactuers Logo Not Showing 9 years 1 month ago #6848

I followed the directions that you suggested and I am having issues showing the Manufactures Logo in place of the name.

Instructions: www.flexiblewebdesign.com/forum-virtuemart-2-template-fashionmart-support/442-providers-logo-on-the-product

Currently Have this in my code. I would like to use the manufacturers logo instead.

<?php if ($this->search ==null) { ?>
<div class="FlexibleCategiryTitle">
<span class="FlexibleCategiryTitleSPAN"><?php echo $this->category->category_name; ?></span>
</div>
<?php } else { ?>
<div class="FlexibleCategiryTitle">
<span class="FlexibleCategiryTitleSPAN"><?php echo JText::_('COM_VIRTUEMART_SEARCH') ?></span>
</div>
<?php } ?>


Code that you suggested: When I apply the code below, nothing shows on the frontend and there is an image in the logo section in the admin panel. Maybe its out of scope. When I place the code down below the (GridViewV2) div, it works! Screenshot attached. (Vendor Logo Here) Any thoughts on what I can do to get this working?

<?php
if (empty($product->mf_images[0]->file_url_thumb)) {
echo ""; // leave here empty so nothing will be visible
} else { ?><?php
$ManufacturerLink = JRoute::_('index.php?option=com_virtuemart&view=manufacturer&virtuemart_manufacturer_id=' . $product->virtuemart_manufacturer_id . '&tmpl=component');
$ManufacturerName = $product->mf_name;
?>
<div class="FlexibleProductDetailsManufacturerLogo">
<a title="<?php echo $ManufacturerName; ?>" rev="iframe|550|650" rel="facebox" href="<?php echo $ManufacturerLink ?>"><img src="<?php echo $product->mf_images[0]->file_url_thumb; ?>" alt="<?php echo $ManufacturerName; ?>" /></a>
</div>
<?php } ?>
Attachments:
The topic has been locked.

Manufactuers Logo Not Showing 9 years 1 month ago #6858

Hi,

You can't put that PHP lines up there (next to product category title).
The manufacturer logo is defined for each product individually (it is not for categories)

Therefore, the line should be added after you start loading up the products. It means; you need to add those PHP lines after you see this line in the category browse page PHP file:
foreach ( $this->products as $product ) {

Furthermore, the manufacturer LOGO's will be printed for ALL products individually. If you want to submit only one manufacturer logo to the top of the category page (next/below/above category title), then you should use the "Category description". Insert an IMAGE (a manufacturer logo) inside the category description field through VM backend, and use this PHP line:
<?php echo $this->category->category_description ; ?>
to print the category description in the category page. (you can copy-paste that line anywhere in the PHP file.)

Regards.
Support & Development
Last Edit: 9 years 1 month ago by Support.
The topic has been locked.

Manufactuers Logo Not Showing 9 years 1 month ago #6872

Got it to work, Cheers!
The topic has been locked.

Manufactuers Logo Not Showing 9 years 1 month ago #6883

Sure, your welcome.

Case solved. Topic is closed.

Regards.
Support & Development
The topic has been locked.
Time to create page: 0.096 seconds

MaterialMart

for Virtuemart 3

Google's Material Design has finally arrived to Virtuemart

Virtumart Template - MaterialMart Virtumart Template - CleanMart Virtumart Template - CleanMart Virtumart Template - CleanMart

Fully responsive!

Buy Now   |   Live Demo