Welcome, Guest
Username: Password: Remember me
Use this Category for your support questions about Joomla Virtuemart Template - DarkMart (SKU# FLEX-00011)

TOPIC: How to confirm that the one-by-one install. is ok

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3786

Hi,

I just install Darkmart on my joomla site :www.pedicure-esperanca.nl/Joomla25 . (Template by artisteer 4.x) (Virtuemart 2.0.20b)

I have followed all the necesary steps according to the tutorial, but i could not manage to get the "darkmart look" on my webshop

Is there a way to check if the installation was succesfull????

I have looked into the topics but could not find any solution.


Please help.

Thanks in advance
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3794

have you enabled the plg_flexible template plugin and configured?
are the darkmart VM files at templates/pedicure_esperansa_v44/html/com_virtuemart ?

I see no references to any of our files in your source code..

Cheers
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3803

Hi John,

Thanks for the fast response.

Can it be that this problem occured because i have installed the virtuemart 2.0 before i had installed my Artisteer 4.x template?
I noticed the same as I examined my template folder. I also couldn't find the com_virtuemart subfolder

If this is the problem, Can I undo the virtuemart installation and install it again???

Thanks in advance
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3806

Hi Sandra -

yes, if you want to just install the VM part of Dark-Mart it has to be installed "into" an existing Joomla templete (the VM templates are subfolders of the Joomla templates effectively)

If you then later install a new Joomla template it knows nothing about your previous VM template

just try copying the complete folder

templates/ORIGINAL_TEMPLATE/html/com_virtuemart

to

templates/pedicure_esperansa_v44/html/

but also we can't give any guarentee that everything will work with an Artiseer Joomla template - they are veiwed with horror by any developer! :(

Cheers
Last Edit: 8 years 5 months ago by John.
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3810

Hi John,

Oeps I had already deleted the original templates. I have copied the com_virtuemart folder located in the flexible_darkmart template folder to the pedicure_esperanca_44 template folder. With firebug I can now see some changes. But if you look to the site you see some error message on the site saying I'm not registered. I have filled the username and ordercode in template and plugin. Is there another place that i have forgotten?

I have read some post on this forum about artisteer 4.1 but If I check there sites it look pretty good.

Thanks in advance
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3816

It all looks such a mess - no css is being loaded, js errors etc etc

I would start a fresh install - Joomla, then Artiseer, then VM, then our one by one...
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3818

Ok i Will do that

Thanks for now
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3853

Dear John,

I made clean joomla 2.5.9 install
- install Template (artisteer) left it not default . I did not removed the standard templates shipped with Joomla
- installed VM >> enabled plugin etc and setup)
- Checked with filezilla if any "com_virtuemart" folder is created in the existing templates. Non of the templates got this folder in /HTML
-installed the one- by one folder
-no results!!

Am i missing something?

VM version 2.0.20b
Artisteer template : Pedesperanca45
Website :http://pedicure-esperanca.nl/j25

It looks like it is not a artisteer problem. Can it be that Virtuemart does not work when install site in subfolder?

pleas help

thanks in advance
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3861

Dear John,

Additional info:

I thought : let me install via kickstart. But the kickstart.php will not run from subfolder. Only from root.
But i have also copied the joomla tool path.php and this works in a subfolder.

If i run kickstart from subfolder , firefox Will do nothing and ieexplorer Will return 500 internal server error.

I hope this will contribute to debugging

Thanks in advance

Best regards
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3863

Hi Sandra,

re Artiseer, never meant this would effect the install - just meant styling issues etc cos Artiseer uses mental css rules, it is always possible - just I wouldn't like to have to do it.. ;)

Re kickstart - this is the standard Akeeba kickstart - there are lots of help on their site about issues you may have with paths etc but this is also Host server dependent as well.

If you can't get it to run then just unpack the zip, use Akeeba's jpa unpacker locally and ftp all the files to your test subfolder - then run the installer.. should work

Re your test installation -

am confused by your explaination (but honestly - this should be so simple - it's just a template)

Install Joomla
Install virtuemart

stop
test everything

install artiserr

stop

test everything

install our template and extensions as per the document (one-by-one)


hope this helps

Cheers
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3867

Hi John,

Yes it should be simple, i agree. I did everything accoording to your last workflow. But no results,

Question:
If i manage the kickstart install. Can i install my template afterwards and copy com_virtuemart to my template like you had explained in previou reply.

Thanks in advance

Best regards
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3868

Oh i see one difference in your workflow and mine.

In your workflow you install frist virtuemart and after that the artisteer template.
I did firtst the artisteer template and after that virtuemart. Is this maybe the problem?

But i thought to have red in your previous anwsers that i had to install first the template. Maybe i understood wrong
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3875

Honestly - shouldn't make any difference - none of it should -

I would advise to try and get a kickstart (or our pre-packaged site) up and running - at least this will give u confidence that it all does work (I mean it does all work - but I know how frustrating stuff like this can become)

As I say - if you expand the big zip then extract with the Akeeba extractor you have the whole site there - upload it and run the normal installer

then you will have this - www.flexiblewebdesign.com/virtuemart-2-template-darkmart/
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3897

Hi John,

I have reached the status : desperate ):

I have Extracted the QuickStart-AkeebaBackup with Akeeba extractor on my PC and transferred the total folder content to www.pedicure-esperanca.nl/j25

after browse to www.pedicure-esperanca.nl/j25

Not working !!!! instead i got
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, This email address is being protected from spambots. You need JavaScript enabled to view it. and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Why can i install a clean joomla 2.5.9 in a this subfolder and not your package??


Please help/advise

thanks in advance
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3899

when I browse to www.pedicure-esperanca.nl/j25 I get the installer! Now install..

or use this link

www.pedicure-esperanca.nl/j25/installation/index.php
Attachments:
Last Edit: 8 years 5 months ago by John.
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3921

Thats because i asked for support at my host provider

I had to comment something out in the .htaccess file
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3922

Ah - we cant be held responible for dodgy hosting providers.. ;)

see it's all working nicely -

now install Artiseer and try copying the html/com_virtuemart

to

templates/pedicure_esperansa_v44/html/
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3927

Dear John

some info for you
Extracting the QuickStart-AkeebaBackup on my PC and transfer it to my serverhost and install did not work for me
(I use Filezilla. I guess filezilla change something in file access rights (All files had 755)

The result was A site with no Template just plain text with hyperlinks

Solution
Copy kickstart.php and QuickStart-AkeebaBackup.zip to the site subfolder. (j25)
On my host I cannot run this in a subfolder
So what I did is copy a .htaccess file to this subfolder . In this file the line "Options +FollowSymLinks" must be commented out

After this I could start kickstart.php from the subfolder.
After going through the installation I try to browse to the site and ...... oeps!!! again 500 internal server error!!!!

So I opened the .htaccess file and saw that the line "Options +FollowSymLinks" was not commented out. Probably the previous .htacces file was overwritten by the DEMO installation package. So I comment it out

Browsed to the site and ...... Its allive (Finally)

Conclusion :
At some hosts one has to comment out the line "Options +FollowSymLinks" in .htaccess in order to run php

I hope this will contribute

Ok my next challenge is to customize the DEMO site to Pedicure-esperanca.nl.

I will keep you informed
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #3928

Excellent - good luck
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4021

Hi John

Until now i could not succeed changing the darkmart template to my template.

Question
If i use only plugin must i select " use virtuemart .css" in template configuration or not
And what to select for catagory and product layout. I see only no overide and default

Please advise

Best regards
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4026

is html/com_virtuemart and all subfolders etc in templates/pedicure_esperansa_v44/html/ ??
is the plugin installed - enabled and your codes inserted?
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4029

Hi John

The joomla site were i installed with kickstart is www.pedicure-esperanca.nl/j25

In this site the darkmart template is working
I installed my template :pedesperanca45

As you can see it is in folder templates/pedesperanca45

Then i copied the com_virtuemart folder located in /templates/flexible_dartmart to / html subfolder of my template
I did this also with mod_vm2card

Is this ok?


So now i want to import my content and menu's from my other joomla25 testsite
Do you know a tool that i can use to export from one joomla site and import to another?
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4033

on www.pedicure-esperanca.nl/j25 is just the darkmart template.. have you selected yours?

for import etc I would just transfer the appropriate db tables across.. but wouldn't be easier to get the site as you want it and then just install the darkmart one-by-one - that's what it is for...

(I assume you have a running J2.5/VM2.0 site that you want darkmart on?)

Cheers
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4035

Hi John

But thats the problem . Untill now the one by one installation did not work for me. Thats Why i installed the kickstart

Ok i'm going to give it another try.

Do you have an example of a site that uses only the vm2 flexible template plugin?

Darkmart example please

Thanks in advance
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4043

Yes - but before your workflow was all a*** about face ;P

basically you need Joomla/Virtuemart and your template of choice all working before installing our extensions

see a few posts back the correct sequence..

it works on other peoples - should be fine on yours but have also given the head developer a heads up on this topic

Cheers
Last Edit: 8 years 5 months ago by John.
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4046

Hello John,

Have a look at www.pedicure-esperanca.nl/Flex and go to E-shop

I think my joomla / virtuemart and template is working fine now

I had some problems fixend in the template . It was still 1.5 compatible ( leeft,right instead of positions etc )

I have installed all com and plg in one by one folder ( flexible)
All plugins are enabled

I have followed the instructions one by one.

Thanks in advance
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4048

Hi,

It is always easier and the best way to go with "QuickStart" package at first, because DarkMart is not just a Joomla or not just a Virtuemart Template, but it is a bundle. It comes with:

- Joomla Template
- Virtuemart Template
- Flexible VM2 Template Plugin
- Shopping Cart Module
- Shopping Cart Plugin
- 3d Slideshow Module

You should follow the One-by One method ONLY if you have already have a website with bunch of pages and modules, and you already have more than 100 products in your Virtuemart. Otherwise, it wouldn't worth it. It would be much time consuming to mess around with One-By one method, because the module position will messed up, you would spend hours to figure out what position is where or try to figure out what the module suffix are etc... It is always easier to see everything in action with the "sample data" installed first and then modify them (instead of re-create things from scratch)

But once you do the QuickStart installation at the beginning, and let say at any time in the future, the new version of DarkMart is released then you can follow the One-By One method and update only what has been updated.
For instance, today DarkMart 2.0 has been released. This update is HUGE and very Important. I would strongly recommend you to get it. Because with this update, DarkMart becomes fully responsive to mobile devices, and the 3D slideshow module has been revised and almost entirely rebuild. Beside it includes some other performance improvement to increase the page loading speed.

For better understanding how the responsiveness is with the new version, browse the DEMO (goo.gl/X2LSG) with your mobile device and you would notice the difference instantly.
I just sent you the download link to your email, download the DarkMart 2.0 from our server, but this time you don't need to proceed to QuickStart, open the One-By One folder and install these to your joomla one-by one.

- mod_flexible_3d_slider.zip
- plg_flexibleTemplate.zip
- tmp_flexible_darkmart.zip

Then you would get all the updates and everything will be just fine.

Regards.
Last Edit: 8 years 5 months ago by Support.
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4050

Hi support team,

So if i understand it's better to use the kickstart installation and then try to customize it to the look and feel of your existing site
I think this will take also a lot of time.

The next workflow I have to follow?

-Install kickstart darkmart 2.0 or update 1.3 to 2.0 using one-by-one folder
-then export all contents/ modules/menus etc from actual site (Is there an easy tool? phpAdmin??)
-then import in site with darkmart 2.0 (Is there an easy tool? phpAdmin maybe ??)
-then customize darkmart template to actual site template (I guess manually)

I think this is also not a easy job I think

I thought the plg_dartmart_template would be like a theme. and that you have to tweak a litle bit


Ok I will try to customize the kickstart installation.

Thanks for the update

Best regards

PS during update 1.3 dartmart to 2.0 With one-by-one install like you suggested, I had a error message . See attacment

Attachment errorDarkmart20.png not found



this happens after I installed tmp_flexible_darkmart.zip
Last Edit: 8 years 5 months ago by Sandra Neves-Gomes.
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4053

Hi Sandra,

don't want to confuse the issue again but don't you already have a successful kickstart install at www.pedicure-esperanca.nl/j25

Is this the one you updated like the boss suggested?

That error is that the language file was missing - but you'll be using the language/nl-NL/nl-NL.tpl_flexible_darkmart.ini anyway?

check that it's there - otherwise you can find it in the zip..

Cheers
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4059

Hi John,

Yes thats the one I have updated to 2.0.

But if you check www.pedicure-esperanca.nl/j25 you can see that the 3D slideshow is not working anymore. Is this because of the big change. How can I fix this so that I can start with an errorles

Thanks in advance

Could you also verify my suggested workflow?

Best regards
Last Edit: 8 years 5 months ago by Sandra Neves-Gomes.
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4061

Hi Support team,

I checked responsiveness on iphone and ipad. My install (Kickstart darkmart 1.3 upgraded to 2.0 does not act responsive at all
www.pedicure-esperanca.nl/j25

Your link (goo.gl/X2LSG) did (responsive)

Is it not better to do a complete new kickstart install of darkmart 2.0? so that I have a good basis

thanks in advance

Best regards
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4066

Hi,

I have reinstalled the dartmart 2.0 kickstart and now it works fine also the responsive behaviour on ipad and iphone
only on firefox it doesn't look good (3D slideshow). In internet explorer it looks nice

Ok it looks like i have to leave artisteer template and customize the darkmart template
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4079

holly shit, really sorry for the trouble Sandra.

I just can't believe myself that i forgot the include the language files in the template installation ZIP.
I am doing it right now. You have ended up with that error because the Language INI files were missing in the installation file.

You can re-download the template from our server (after ten minutes I post this reply) i am going to patch it right now.

Regards.
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4080

And most importantly, to make the template responsive; don't forget to enable this option through Template Configuration:


Attachment Pasted_Image_4_9_13_1_58_AM.gif not found

The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4082

Hi Mr. Support ,

No problem. I just re-downloaded the zip file. I have already done some adjustment to the template. How must i install the language files?

Thanks for posting the screen dump because I didnt had an idea tha there was a profile tab. I think that its not clear displayed in that back_end template of joomla 2.5.9.

Ok thanks for the support for now.


Best regards
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4093

Hi Sandra - will be enough just to find the lang file you need (nl-NL.tpl_flexible_darkmart.ini) and upload it to

language/nl-NL/
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4100

Thanks!!! John
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4105

Hi Support/John,

I think i'm on the right track. (www.pedicure-esperanca.nl/j25)

The only problem is that IEexplorer will not present background colors. In firefox its ok . could you tell me what i do wrong????

thanks in advance

Sandra
The topic has been locked.

How to confirm that the one-by-one install. is ok 8 years 5 months ago #4108

IE will never understand -moz-linear-gradient

moz -> Mozilla - get it? hint hint

you need as well

filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#000000', endColorstr='#454545');

www.pedicure-esperanca.nl/j25/templates/flexible_darkmart/css/customizeColors.css

google crossbrowser gradients - you'll need some webkit as well for Chrome etc
The topic has been locked.
Time to create page: 0.118 seconds

MaterialMart

for Virtuemart 3

Google's Material Design has finally arrived to Virtuemart

Virtumart Template - MaterialMart Virtumart Template - CleanMart Virtumart Template - CleanMart Virtumart Template - CleanMart

Fully responsive!

Buy Now   |   Live Demo